What's new

Connecting to server issues

Status
Not open for further replies.

Llamas

Lead Administrator
Joined
Jan 20, 2012
Messages
2,894
Location
Cooper City, Florida
Where to begin,Where to begin.... Bascially this all started on Saturday when I was having some internet issues which was basically randomly slowing down, ping spikes etc. The few times I tried to get onto samp it would always dsync me right when I logged in but now its something super different today.

Today my internet seems normal with no ping spikes or anything but when I seem to log into RCRP I get either the following 3 things:

You're banned from the server
Server closed connect - As I spawn in.
General dsync after I have to click "Spawn" after selecting my character.

I can also play on other samp servers fine.

I also did reset my router plenty of times after the banned from server thing but then goes into the next item on the list etc etc.

I fail to see how this can be a ISP issue but I will be calling them later today. Figured I would post this and see if it could be anything else besides hopefully just a ISP issue.

Any help or ideas would be greatly helpful cause right now. Not really sure what else to do.

Thanks - Llamaman <3
 

Matty

Donator
Joined
Nov 23, 2011
Messages
3,750
Location
Flanders, Belgium
EDIT: I had this issue aswell, this was when the server glitched because the script/server thought I was online, when I really wasn't (even your admin magic showed me as online), getting somebody to disable and re-enable your account from the UCP worked for me.

1) Run fr0st's diagnostic tool and post the results, maybe we can find anything there.
2) http://canyouseeme.org/, go on there and check port 7777 (if it says connection refused, skip this step, firewall issue I guess, I have it too and can connect fine).
3) Could be a server related issue, perhaps with the server rejecting your connection cookie because of high amounts of lag, or a malicious, corrupt or malformed request, try asking Tommy for a server restart.
4) Perhaps an ISP issue as you said, try contacting them to see if they're experiencing any issues.
 

Llamas

Lead Administrator
Joined
Jan 20, 2012
Messages
2,894
Location
Cooper City, Florida
Matty said:
EDIT: I had this issue aswell, this was when the server glitched because the script/server thought I was online, when I really wasn't (even your admin magic showed me as online), getting somebody to disable and re-enable your account from the UCP worked for me.

1) Run fr0st's diagnostic tool and post the results, maybe we can find anything there.
2) http://canyouseeme.org/, go on there and check port 7777 (if it says connection refused, skip this step, firewall issue I guess, I have it too and can connect fine).
3) Could be a server related issue, perhaps with the server rejecting your connection cookie because of high amounts of lag, or a malicious, corrupt or malformed request, try asking Tommy for a server restart.
4) Perhaps an ISP issue as you said, try contacting them to see if they're experiencing any issues.
1) http://pastebin.com/rTw53pHU
2) Error: I could not see your service on 108*** on port (7777)
Reason: Connection timed out
3)
TommyB said:
4) From online searches and stuff they seem to be having no issues in our area. Will probably try to call later but since I've had normal pings/full bars all day today unlike the last 2 days. I fail to see that being the main factor unless proven.
 

Matty

Donator
Joined
Nov 23, 2011
Messages
3,750
Location
Flanders, Belgium
Llamas said:
Matty said:
EDIT: I had this issue aswell, this was when the server glitched because the script/server thought I was online, when I really wasn't (even your admin magic showed me as online), getting somebody to disable and re-enable your account from the UCP worked for me.

1) Run fr0st's diagnostic tool and post the results, maybe we can find anything there.
2) http://canyouseeme.org/, go on there and check port 7777 (if it says connection refused, skip this step, firewall issue I guess, I have it too and can connect fine).
3) Could be a server related issue, perhaps with the server rejecting your connection cookie because of high amounts of lag, or a malicious, corrupt or malformed request, try asking Tommy for a server restart.
4) Perhaps an ISP issue as you said, try contacting them to see if they're experiencing any issues.
1) http://pastebin.com/rTw53pHU
2) Error: I could not see your service on 108*** on port (7777)
Reason: Connection timed out
3)
TommyB said:
4) From online searches and stuff they seem to be having no issues in our area. Will probably try to call later but since I've had normal pings/full bars all day today unlike the last 2 days. I fail to see that being the main factor unless proven.

You sure you posted the entire result in 1)?
 

Witting

Donator
Joined
Aug 12, 2014
Messages
2,628
Had a similar problem. Literally just left it for a couple days and tried again and it worked.

Either that or I just reinstalled SAMP. I don't think there's a great fix for this issue.
 

Matty

Donator
Joined
Nov 23, 2011
Messages
3,750
Location
Flanders, Belgium
Llamas said:
Matty said:
Also try to connect to other servers with port 7777, and then to any other port, perhaps a port issue.
This is one I did earlier - http://pastebin.com/cHRywWx9

Also, Other servers work for me like the mapping server, TDM servers etc. Is that what you mean by that?
Yeah but look at the server's IP address at the bottom of your SA-MP client:


The four last numbers are the port, try connecting to one that IS also 7777 but is not RC-RP, and then try connecting to one that ISN'T 7777, if your connection gets refused with 7777 and not others, we know it's a port issue.
 

Llamas

Lead Administrator
Joined
Jan 20, 2012
Messages
2,894
Location
Cooper City, Florida
Matty said:
Llamas said:
Matty said:
Also try to connect to other servers with port 7777, and then to any other port, perhaps a port issue.
This is one I did earlier - http://pastebin.com/cHRywWx9

Also, Other servers work for me like the mapping server, TDM servers etc. Is that what you mean by that?
Yeah but look at the server's IP address at the bottom of your SA-MP client:


The four last numbers are the port, try connecting to one that IS also 7777 but is not RC-RP, and then try connecting to one that ISN'T 7777, if your connection gets refused with 7777 and not others, we know it's a port issue.
Alright, Let me see if I can find a server to try

Edit: Tried a few TDM servers with 7777 and they work perfect.

Guess hopefully like witting said and it will work some day.
 

Matty

Donator
Joined
Nov 23, 2011
Messages
3,750
Location
Flanders, Belgium
Llamas said:
Matty said:
Llamas said:
Matty said:
Also try to connect to other servers with port 7777, and then to any other port, perhaps a port issue.
This is one I did earlier - http://pastebin.com/cHRywWx9

Also, Other servers work for me like the mapping server, TDM servers etc. Is that what you mean by that?
Yeah but look at the server's IP address at the bottom of your SA-MP client:


The four last numbers are the port, try connecting to one that IS also 7777 but is not RC-RP, and then try connecting to one that ISN'T 7777, if your connection gets refused with 7777 and not others, we know it's a port issue.
Alright, Let me see if I can find a server to try

Edit: Tried a few TDM servers with 7777 and they work perfect.

Guess hopefully like witting said and it will work some day.
I'm out of ideas, but yeah, this happens more often (Zodiac, for example) and usually sorts itself in a few days.
 
Status
Not open for further replies.
Top