Logging on to the forums with Firefox

Status
Not open for further replies.
Joined
Aug 16, 2012
Messages
292
Likes
0
IG Name
Steven Hinckle
#1
I'm on SHITernet Explorer right now just to post this. Google Chrome won't stop crashing, and firefox won't let me login. I get to the screen that says thanks for logging in or something, then it redirects. When it redirects, it automaticly logs me out. I really need help with this be I hate Internet Explorer with a firey passion and want to use it a little as possible. Thanks in advance.
 

T-Rock

Silver Member
Joined
Apr 4, 2013
Messages
1,027
Likes
0
IG Name
Donald_Rockefeller
IG Faction
Elite Trucking Co.
#2
I would suggest you to delete all of your browsers and download the last version of Microsoft Firefox, if you wish. Don't stop the scripts of it, also remove all of the advertisements, you can do that in your options. Also there is a nice browsers called "Opera", I am using it at the moment and haven't even got any problems with it. One more question, you are crashing only when you try to log in our forum or in each page? :O
 
Joined
Aug 16, 2012
Messages
292
Likes
0
IG Name
Steven Hinckle
#3
Google Chrome crashes on every page. Firefox just won't let me log into THIS forum. Every other forum and even the master account works. I'll check out Opera though.

EDIT: This can be locked. Thank you, T-Rock, for showing me Opera. I will just stick with this as it resembles Google Chrome.
 

T-Rock

Silver Member
Joined
Apr 4, 2013
Messages
1,027
Likes
0
IG Name
Donald_Rockefeller
IG Faction
Elite Trucking Co.
#4
You're welcome! I hope the Opera will run all of the pages okay. Good luck with it. Locked and Archived.
 
Status
Not open for further replies.