What's new

Letting others connect to your SA:MP server

Status
Not open for further replies.

Thomasz

Banned
Joined
Dec 29, 2013
Messages
5,186
Location
Belgium
Hello there, I wasn't sure wether I would put this in the SAMP discussion, or help, as it is a bit of both, I decided to post on both:

I have recently started experimenting with SA:MP scripting, I have been testing my server at a localhost (127.0.0.1) if im not mistaken, something like that. I'd like to know how I can make it public, how others can connect to my server.
 

Prescription

Donator
Joined
Mar 10, 2012
Messages
2,571
Port forward (see a tutorial it's different for every ISP) preferably to 7777.
Then go to IPChicken.com and give them that IP.
 

Giga

Donator
Joined
Dec 4, 2010
Messages
18,989
Location
MNL
This should indeed be in the SAMP board, but anyway, have you made sure you've set 'announce' to '1' on the server configuration file? Also, you'll need to port forward your modem/route to allow inbound and outbound connections to port 7777.
 

Thomasz

Banned
Joined
Dec 29, 2013
Messages
5,186
Location
Belgium
Giga said:
This should indeed be in the SAMP board, but anyway, have you made sure you've set 'announce' to '1' on the server configuration file? Also, you'll need to port forward your modem/route to allow inbound and outbound connections to port 7777.
I've done both.
 

Thomasz

Banned
Joined
Dec 29, 2013
Messages
5,186
Location
Belgium
BenBiddulph said:
Port forward (see a tutorial it's different for every ISP) preferably to 7777.
Then go to IPChicken.com and give them that IP.
I did, its stuck on "Retrieving Info"
 

Giga

Donator
Joined
Dec 4, 2010
Messages
18,989
Location
MNL
Have you enabled the port from your firewall? TCP and UDP.
 

Thomasz

Banned
Joined
Dec 29, 2013
Messages
5,186
Location
Belgium
Giga said:
Have you enabled the port from your firewall? TCP and UDP.
EDIT:

Appareantly I need to port forward from my router aswell, but to access my router i have to put in the IP adress in my browser, (Default Gateway one), and it gives me an error instead of taking me to the control panel.

ERR_CONNECTION_TIMED_OUT
 

Thomasz

Banned
Joined
Dec 29, 2013
Messages
5,186
Location
Belgium
When i try the IPV4 adress it gives me:

Forbidden

You don't have permission to access / on this server.
 

Manu

Retired Admin
Joined
Apr 7, 2013
Messages
5,098
Location
Flanders, Belgium
Do you try to connect to 192.168.1.1? That should work by default though-..
HMU on facebook I'll try to help you
 

Giga

Donator
Joined
Dec 4, 2010
Messages
18,989
Location
MNL
You can also search for the gateway address on Google. Just type in your router model + gateway address
 
Status
Not open for further replies.
Top