What's new

Incredible packet loss and desyncing

Status
Not open for further replies.

JRamirez

Member
Joined
Jun 19, 2014
Messages
17
Location
Italy
Up to a few days ago I started having a lot of packets losses and I was getting desynced more than usual.. Fast forward two days and I'm losing packets 9/10 of the time and I'm desynced every 5 minutes. It happens a lot during peak times but less when players are few. I'll post my rcrp.testresults.txt below under spoilers and you'll notice that I'm losing around 25 percent of the tested packets while my connection is totally fine with a ping of 9-20 ms and no packets lost when connecting with google. I live in Italy if that may help.
Running RC-RP Diagnostics test...
Retrieving system date and time.
12-Jul-17
08:51 PM

------- Ping/Traceroute to EU.FROSTGAMING.COM -------:

Pinging eu.frostgaming.com [164.132.200.17] with 32 bytes of data:
Reply from 164.132.200.17: bytes=32 time=51ms TTL=50
Reply from 164.132.200.17: bytes=32 time=49ms TTL=50
Request timed out.
Reply from 164.132.200.17: bytes=32 time=46ms TTL=50
Reply from 164.132.200.17: bytes=32 time=46ms TTL=50
Reply from 164.132.200.17: bytes=32 time=45ms TTL=50
Reply from 164.132.200.17: bytes=32 time=60ms TTL=50
Reply from 164.132.200.17: bytes=32 time=128ms TTL=50

Ping statistics for 164.132.200.17:
Packets: Sent = 8, Received = 7, Lost = 1 (12% loss),
Approximate round trip times in milli-seconds:
Minimum = 45ms, Maximum = 128ms, Average = 60ms

Tracing route to eu.frostgaming.com [164.132.200.17]
over a maximum of 30 hops:

1 2 ms 2 ms 2 ms 192.168.1.254
2 31 ms 29 ms 28 ms 100.84.32.1
3 28 ms 28 ms 29 ms 10.250.132.190
4 33 ms 28 ms 30 ms 10.2.42.90
5 31 ms 29 ms 29 ms 10.2.42.85
6 29 ms 49 ms 29 ms 10.254.12.157
7 32 ms 40 ms 42 ms 62.101.124.129
8 39 ms 31 ms 30 ms 89.96.200.46
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 45 ms 45 ms 46 ms 164.132.200.17

Trace complete.

------- Ping/Traceroute to SERVER.REDCOUNTYRP.COM -------:

Pinging server.redcountyrp.com [178.32.108.245] with 32 bytes of data:
Reply from 178.32.108.245: bytes=32 time=49ms TTL=50
Request timed out.
Reply from 178.32.108.245: bytes=32 time=51ms TTL=50
Reply from 178.32.108.245: bytes=32 time=51ms TTL=50
Reply from 178.32.108.245: bytes=32 time=46ms TTL=50
Reply from 178.32.108.245: bytes=32 time=49ms TTL=50
Reply from 178.32.108.245: bytes=32 time=48ms TTL=50
Request timed out.

Ping statistics for 178.32.108.245:
Packets: Sent = 8, Received = 6, Lost = 2 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 46ms, Maximum = 51ms, Average = 49ms

Tracing route to server.redcountyrp.com [178.32.108.245]
over a maximum of 30 hops:

1 2 ms 2 ms 2 ms 192.168.1.254
2 28 ms 29 ms 29 ms 100.84.32.1
3 30 ms 28 ms 28 ms 10.250.132.186
4 28 ms 28 ms 28 ms 10.2.42.90
5 40 ms 31 ms 30 ms 10.2.42.81
6 57 ms 62 ms 65 ms 10.254.12.153
7 68 ms 57 ms 34 ms 62-101-124-98.fastres.net [62.101.124.98]
8 61 ms 28 ms 67 ms 89.96.200.46
9 * * * Request timed out.
10 47 ms 48 ms 47 ms b [213.186.32.212]
11 * * * Request timed out.
12 * * * Request timed out.
13 47 ms 49 ms 49 ms ip245.ip-178-32-108.eu [178.32.108.245]

Trace complete.

------- Ping/Traceroute to GOOGLE.COM -------:

Pinging google.com [172.217.23.78] with 32 bytes of data:
Reply from 172.217.23.78: bytes=32 time=33ms TTL=53
Reply from 172.217.23.78: bytes=32 time=28ms TTL=53
Reply from 172.217.23.78: bytes=32 time=28ms TTL=53
Reply from 172.217.23.78: bytes=32 time=29ms TTL=53

Ping statistics for 172.217.23.78:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 28ms, Maximum = 33ms, Average = 29ms

Tracing route to google.com [172.217.23.78]
over a maximum of 30 hops:

1 2 ms 2 ms 2 ms 192.168.1.254
2 30 ms 29 ms 30 ms 100.84.32.1
3 29 ms 28 ms 28 ms 10.250.132.190
4 79 ms 29 ms 28 ms 10.2.42.90
5 30 ms 28 ms 28 ms 10.2.42.81
6 51 ms 48 ms 48 ms 10.254.12.153
7 31 ms 30 ms 29 ms 62-101-124-94.fastres.net [62.101.124.94]
8 28 ms 28 ms 30 ms 89.96.200.122
9 47 ms 45 ms 47 ms 72.14.216.165
10 60 ms 29 ms 29 ms 108.170.245.65
11 29 ms 29 ms 28 ms 108.177.3.77
12 29 ms 29 ms 29 ms mil04s22-in-f78.1e100.net [172.217.23.78]

Trace complete.

IPconfig information:

Windows IP Configuration

Host Name . . . . . . . . . . . . : Derry
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : lan

Ethernet adapter VPN - VPN Client:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VPN Client Adapter - VPN #2
Physical Address. . . . . . . . . : 00-AC-14-D5-B9-D0
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Qualcomm Atheros QCA9377 Wireless Network Adapter
Physical Address. . . . . . . . . : 30-F7-72-43-8D-83
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Connessione alla rete locale (LAN)* 5:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : 32-F7-72-43-8D-83
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 54-AB-3A-4B-A1-0A
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::fc68:da49:8a0d:d248%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.110(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, 12 July, 2017 12:02:09 PM
Lease Expires . . . . . . . . . . : Thursday, 13 July, 2017 8:42:45 AM
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DHCPv6 IAID . . . . . . . . . . . : 240429882
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-66-CF-E4-54-AB-3A-4B-A1-0A
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Connessione alla rete locale (LAN)* 13:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:493:1418:a2d7:48c(Preferred)
Link-local IPv6 Address . . . . . : fe80::493:1418:a2d7:48c%19(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 268435456
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-66-CF-E4-54-AB-3A-4B-A1-0A
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.lan:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

*****Test Complete*****!
09:13 PM
12-Jul-17
 

Curty

Donator
Joined
Jun 13, 2017
Messages
1,128
Location
Bristol, England
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
 

TommyB

spotify listener
Owner
Joined
Dec 30, 2010
Messages
18,677
Location
Texas, USA.
curtis111 said:
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
no our host is fine and our server load is also fine, actually. this usually boils down to individual cases of bad connection to the server which could exist for a number of different reasons.
 

Curty

Donator
Joined
Jun 13, 2017
Messages
1,128
Location
Bristol, England
TommyB said:
curtis111 said:
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
no our host is fine and our server load is also fine, actually. this usually boils down to individual cases of bad connection to the server which could exist for a number of different reasons.
Oh, I'm mistaken then. But I and a lot of other people can all agree that we desync a lot more on RCRP than other servers. I've noticed it.
 

JRamirez

Member
Joined
Jun 19, 2014
Messages
17
Location
Italy
curtis111 said:
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
My object limit is 350 and the only mod I have is ImVehFT. RCRP is the only server where I desync a lot while in other samp servers my connection's totally stable. If its not server side I dont know what it is.
 

JRamirez

Member
Joined
Jun 19, 2014
Messages
17
Location
Italy
no our host is fine and our server load is also fine, actually. this usually boils down to individual cases of bad connection to the server which could exist for a number of different reasons.
Do you mind troubleshooting me with those reasons?
 

Curty

Donator
Joined
Jun 13, 2017
Messages
1,128
Location
Bristol, England
JRamirez said:
curtis111 said:
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
My object limit is 350 and the only mod I have is ImVehFT. RCRP is the only server where I desync a lot while in other samp servers my connection's totally stable. If its not server side I dont know what it is.

I must admit that I too, desync abnormally more on RCRP.
 

JRamirez

Member
Joined
Jun 19, 2014
Messages
17
Location
Italy
curtis111 said:
JRamirez said:
curtis111 said:
I think the issue is down to the server's hosting company. This happens to a number of players that I know because I've asked the same thing before and someone said they desync on RCRP more than any other server so I guess it's the host or maybe the maps, not sure. You could try and solve this by setting your object limit lower and removing mods etc.
My object limit is 350 and the only mod I have is ImVehFT. RCRP is the only server where I desync a lot while in other samp servers my connection's totally stable. If its not server side I dont know what it is.

I must admit that I too, desync abnormally more on RCRP.
Alright now I am 99 percent sure. During the morning and early afternoon where to players are below 100 I experience no desyncing AT ALL, my connection's totally normal and packet loss is at a stable 0.0 percent. Now I've went and logged in when the server is at over 120 players and I desync almost immediately and the packet loss is so high its unplayable. Those that have very fast connections have no problem but I have a 1.7 mb/s download connection and apparently its not enough to prevent packet loss. Several other players experience the same problem while others dont.
 
Status
Not open for further replies.
Top